re = /\{(?:[^{}]*|(?R))+\}/m
str = '\'<script type="application/ld+json">
{"some_key":
["some_item": {
["some_nested_items1", "some_nested_items1"]
}]
}
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end