// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\{(?:[^{}]*|(?R))+\}").unwrap();
let string = "'<script type=\"application/ld+json\">
{\"some_key\":
[\"some_item\": {
[\"some_nested_items1\", \"some_nested_items1\"]
}]
}
</script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}