#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<==)[^=]*(?=\[OO\])"
Local $sString = "a=b&c=blablabla_[OO]"
Local $sSubst = "REPLACEMENT"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)