use strict;
my $str = 'a=b&c=blablabla_[OO]';
my $regex = qr/(?<==)[^=]*(?=\[OO\])/mp;
my $subst = 'REPLACEMENT';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";