import Foundation
let pattern = #"(?<==)[^=]*(?=\[OO\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"a=b&c=blablabla_[OO]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"REPLACEMENT"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)