using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<==)[^=]*(?=\[OO\])";
string substitution = @"REPLACEMENT";
string input = @"a=b&c=blablabla_[OO]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}