$re = '/(?<==)[^=]*(?=\[OO\])/m';
$str = 'a=b&c=blablabla_[OO]';
$subst = "REPLACEMENT";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;