use strict;
my $str = ' sdf
asdasd sdf
ss sdf
asd
dsa
asd
asd
asd
asd
asd
asd';
my $regex = qr/^([[:space:]]+)(.*)$/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";