import re
regex = re.compile(r"^([[:space:]]+)(.*)$", flags=re.MULTILINE)
test_str = (" sdf\n"
" asdasd sdf\n"
" ss sdf\n"
"asd\n"
"dsa\n"
" asd\n"
" asd\n"
" asd\n"
" asd\n"
" asd\n"
"asd")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)