$re = '/^([[:space:]]+)(.*)$/m';
$str = ' sdf
asdasd sdf
ss sdf
asd
dsa
asd
asd
asd
asd
asd
asd';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;