#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(?(\d{3})\)?[-\h]?(\d{3})[-)\h]?(\d{4})\h*(?:e?x?t?(?:ension)?\h(\d+))?"
Local $sString = "$tests[] = "941-751-6550 ext 2204";" & @CRLF & _
"$tests[] = "(941) 751-6550 ext 2204";" & @CRLF & _
"$tests[] = "(941)751-6550 ext 2204";" & @CRLF & _
"$tests[] = "9417516550 ext 2204";" & @CRLF & _
"$tests[] = "941-751-6550 e 2204";" & @CRLF & _
"$tests[] = "941-751-6550 ext 2204 ";" & @CRLF & _
"$tests[] = "941-751-6550 extension 2204";" & @CRLF & _
"$tests[] = "941-751-6550 x2204";" & @CRLF & _
"$tests[] = "(941) 751-6550";" & @CRLF & _
"$tests[] = "(941)7516550";" & @CRLF & _
"$tests[] = "941-751-6550 ";" & @CRLF & _
"$tests[] = "941-751-6550";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")