import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(?(\\d{3})\\)?[-\\h]?(\\d{3})[-)\\h]?(\\d{4})\\h*(?:e?x?t?(?:ension)?\\h(\\d+))?";
final String string = "$tests[] = \"941-751-6550 ext 2204\";\n"
+ "$tests[] = \"(941) 751-6550 ext 2204\";\n"
+ "$tests[] = \"(941)751-6550 ext 2204\";\n"
+ "$tests[] = \"9417516550 ext 2204\";\n"
+ "$tests[] = \"941-751-6550 e 2204\";\n"
+ "$tests[] = \"941-751-6550 ext 2204 \";\n"
+ "$tests[] = \"941-751-6550 extension 2204\";\n"
+ "$tests[] = \"941-751-6550 x2204\";\n"
+ "$tests[] = \"(941) 751-6550\";\n"
+ "$tests[] = \"(941)7516550\";\n"
+ "$tests[] = \"941-751-6550 \";\n"
+ "$tests[] = \"941-751-6550\";";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}