// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\(?(\d{3})\)?[-\h]?(\d{3})[-)\h]?(\d{4})\h*(?:e?x?t?(?:ension)?\h(\d+))?").unwrap();
let string = "$tests[] = \"941-751-6550 ext 2204\";
$tests[] = \"(941) 751-6550 ext 2204\";
$tests[] = \"(941)751-6550 ext 2204\";
$tests[] = \"9417516550 ext 2204\";
$tests[] = \"941-751-6550 e 2204\";
$tests[] = \"941-751-6550 ext 2204 \";
$tests[] = \"941-751-6550 extension 2204\";
$tests[] = \"941-751-6550 x2204\";
$tests[] = \"(941) 751-6550\";
$tests[] = \"(941)7516550\";
$tests[] = \"941-751-6550 \";
$tests[] = \"941-751-6550\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}