const regex = /\(?(\d{3})\)?[-\h]?(\d{3})[-)\h]?(\d{4})\h*(?:e?x?t?(?:ension)?\h(\d+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(?(\\d{3})\\)?[-\\h]?(\\d{3})[-)\\h]?(\\d{4})\\h*(?:e?x?t?(?:ension)?\\h(\\d+))?', 'g')
const str = `\$tests[] = "941-751-6550 ext 2204";
\$tests[] = "(941) 751-6550 ext 2204";
\$tests[] = "(941)751-6550 ext 2204";
\$tests[] = "9417516550 ext 2204";
\$tests[] = "941-751-6550 e 2204";
\$tests[] = "941-751-6550 ext 2204 ";
\$tests[] = "941-751-6550 extension 2204";
\$tests[] = "941-751-6550 x2204";
\$tests[] = "(941) 751-6550";
\$tests[] = "(941)7516550";
\$tests[] = "941-751-6550 ";
\$tests[] = "941-751-6550";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}