re = /\(?(\d{3})\)?[-\h]?(\d{3})[-)\h]?(\d{4})\h*(?:e?x?t?(?:ension)?\h(\d+))?/
str = '$tests[] = "941-751-6550 ext 2204";
$tests[] = "(941) 751-6550 ext 2204";
$tests[] = "(941)751-6550 ext 2204";
$tests[] = "9417516550 ext 2204";
$tests[] = "941-751-6550 e 2204";
$tests[] = "941-751-6550 ext 2204 ";
$tests[] = "941-751-6550 extension 2204";
$tests[] = "941-751-6550 x2204";
$tests[] = "(941) 751-6550";
$tests[] = "(941)7516550";
$tests[] = "941-751-6550 ";
$tests[] = "941-751-6550";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end