using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2}[\/ ](\d{2}|January|Jan)[\/ ]\d{2,4})";
string input = @"12/12/2017
12/18/2017
12 January 2017
12 Jan 17
I want to apply for leaves from 12/12/2017 to 12/18/2017 I want to apply for leaves from 12 January 2017 to 12/18/2017 I want to apply for leaves from 12/12/2017 to 12 Jan 17 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}