package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{2}[\/ ](\d{2}|January|Jan)[\/ ]\d{2,4})`)
var str = `12/12/2017
12/18/2017
12 January 2017
12 Jan 17
I want to apply for leaves from 12/12/2017 to 12/18/2017 I want to apply for leaves from 12 January 2017 to 12/18/2017 I want to apply for leaves from 12/12/2017 to 12 Jan 17 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}