import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}[\\/ ](\\d{2}|January|Jan)[\\/ ]\\d{2,4})";
final String string = "12/12/2017\n"
+ "12/18/2017\n"
+ "12 January 2017\n"
+ "12 Jan 17\n"
+ "I want to apply for leaves from 12/12/2017 to 12/18/2017 I want to apply for leaves from 12 January 2017 to 12/18/2017 I want to apply for leaves from 12/12/2017 to 12 Jan 17 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}