const regex = /(\d{2}[\/ ](\d{2}|January|Jan)[\/ ]\d{2,4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2}[\\\/ ](\\d{2}|January|Jan)[\\\/ ]\\d{2,4})', 'g')
const str = `12/12/2017
12/18/2017
12 January 2017
12 Jan 17
I want to apply for leaves from 12/12/2017 to 12/18/2017 I want to apply for leaves from 12 January 2017 to 12/18/2017 I want to apply for leaves from 12/12/2017 to 12 Jan 17 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}