// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{2}[\/ ](\d{2}|January|Jan)[\/ ]\d{2,4})").unwrap();
let string = "12/12/2017
12/18/2017
12 January 2017
12 Jan 17
I want to apply for leaves from 12/12/2017 to 12/18/2017 I want to apply for leaves from 12 January 2017 to 12/18/2017 I want to apply for leaves from 12/12/2017 to 12 Jan 17 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}