#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\- ]+"
Local $sString = "Link_Info-mc1.7.10-0.3.1.litemod" & @CRLF & _
"Mantle-1.7.10-0.3.2.jar" & @CRLF & _
"MicdoodleCore-1.7-3.0.11.333.jar" & @CRLF & _
"MineTweaker3-1.7.10-3.0.9C.jar" & @CRLF & _
"ModTweaker 2-0.8.0.jar" & @CRLF & _
"MouseTweaks-2.4.4-mc1.7.10.jar" & @CRLF & _
"NEIIntegration-MC1.7.10-1.0.9.jar" & @CRLF & _
"NotEnoughItems-1.7.10-1.0.5.110-universal.jar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")