const regex = /^[^\- ]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\- ]+', 'gm')
const str = `Link_Info-mc1.7.10-0.3.1.litemod
Mantle-1.7.10-0.3.2.jar
MicdoodleCore-1.7-3.0.11.333.jar
MineTweaker3-1.7.10-3.0.9C.jar
ModTweaker 2-0.8.0.jar
MouseTweaks-2.4.4-mc1.7.10.jar
NEIIntegration-MC1.7.10-1.0.9.jar
NotEnoughItems-1.7.10-1.0.5.110-universal.jar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}