# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\- ]+"
test_str = ("Link_Info-mc1.7.10-0.3.1.litemod\n"
"Mantle-1.7.10-0.3.2.jar\n"
"MicdoodleCore-1.7-3.0.11.333.jar\n"
"MineTweaker3-1.7.10-3.0.9C.jar\n"
"ModTweaker 2-0.8.0.jar\n"
"MouseTweaks-2.4.4-mc1.7.10.jar\n"
"NEIIntegration-MC1.7.10-1.0.9.jar\n"
"NotEnoughItems-1.7.10-1.0.5.110-universal.jar")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.