// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\- ]+").unwrap();
let string = "Link_Info-mc1.7.10-0.3.1.litemod
Mantle-1.7.10-0.3.2.jar
MicdoodleCore-1.7-3.0.11.333.jar
MineTweaker3-1.7.10-3.0.9C.jar
ModTweaker 2-0.8.0.jar
MouseTweaks-2.4.4-mc1.7.10.jar
NEIIntegration-MC1.7.10-1.0.9.jar
NotEnoughItems-1.7.10-1.0.5.110-universal.jar";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}