#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bcalc\([\s\S]*?\)"
Local $sString = "h1 {" & @CRLF & _
" font-size: calc( 1rem * 1.26 * 1.26 * 1.26 );" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" h1 {" & @CRLF & _
" font-size: calc( " & @CRLF & _
" 1rem " & @CRLF & _
" * 1.26 " & @CRLF & _
" * 1.26" & @CRLF & _
" * 1.26" & @CRLF & _
" );" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")