package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bcalc\([\s\S]*?\)`)
var str = `h1 {
font-size: calc( 1rem * 1.26 * 1.26 * 1.26 );
}
h1 {
font-size: calc(
1rem
* 1.26
* 1.26
* 1.26
);
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}