const regex = /\bcalc\([\s\S]*?\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bcalc\\([\\s\\S]*?\\)', 'g')
const str = `h1 {
font-size: calc( 1rem * 1.26 * 1.26 * 1.26 );
}
h1 {
font-size: calc(
1rem
* 1.26
* 1.26
* 1.26
);
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}