re = /\bcalc\([\s\S]*?\)/
str = 'h1 {
font-size: calc( 1rem * 1.26 * 1.26 * 1.26 );
}
h1 {
font-size: calc(
1rem
* 1.26
* 1.26
* 1.26
);
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end