const regex = /[\p{Sc}\p{So}\p{Mn}\p{P}\p{Z}À-ÿ]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\p{Sc}\\p{So}\\p{Mn}\\p{P}\\p{Z}À-ÿ]', 'gm')
const str = `QWERTYUIOPéAsdfghjklHFIUSAF /*-+!"£\$%&/()?=^*é§°ç_:;[]#@€£█Õ○3═nêj⌂8±£#♫♣èùàò`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}