// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\p{Sc}\p{So}\p{Mn}\p{P}\p{Z}À-ÿ]").unwrap();
let string = "QWERTYUIOPéAsdfghjklHFIUSAF /*-+!\"£$%&/()?=^*é§°ç_:;[]#@€£█Õ○3═nêj⌂8±£#♫♣èùàò";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}