const regex = /(
(\d+|pi|\\u03C0|\\u03A0|phi|\\u03C6|\\u03A6)
|
(abs|acos|cos|atan|tan|asin|sin|ceil|floor|sqrt|log|ln)\([^)]+\)
)
(
\s*([+\-*\/^]|mod)\s*
(
(\d+|pi|\\u03C0|\\u03A0|phi|\\u03C6|\\u03A6)
|
(abs|acos|cos|atan|tan|asin|sin|ceil|floor|sqrt|log|ln)\([^)]+\)
)
)*
\s*=/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(
(\\d+|pi|\\\\u03C0|\\\\u03A0|phi|\\\\u03C6|\\\\u03A6)
|
(abs|acos|cos|atan|tan|asin|sin|ceil|floor|sqrt|log|ln)\\([^)]+\\)
)
(
\\s*([+\\-*\\\/^]|mod)\\s*
(
(\\d+|pi|\\\\u03C0|\\\\u03A0|phi|\\\\u03C6|\\\\u03A6)
|
(abs|acos|cos|atan|tan|asin|sin|ceil|floor|sqrt|log|ln)\\([^)]+\\)
)
)*
\\s*=', 'g')
const str = `test text (1) pi=
test text (1 pi=
test text 1) pi=
test text (2) pi + 10 / 20=
test text (3) test pi ^ 10 / 20=
test text (30) 10 + 5=
test text (500) abs(10 + 5)=
test text (1) pi + 10 / 20=
test text 10*5=
test text pi / phi=
test text 10 mod phi=
test text 50 10 mod phi=
test text pi mod abs(phi)=
apple banana cherry apple 10 apple cherry banana hi 10 99+1=
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}