# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(
(\d+|pi|\\u03C0|\\u03A0|phi|\\u03C6|\\u03A6)
|
(abs|acos|cos|atan|tan|asin|sin|ceil|floor|sqrt|log|ln)\([^)]+\)
)
(
\s*([+\-*\/^]|mod)\s*
(
(\d+|pi|\\u03C0|\\u03A0|phi|\\u03C6|\\u03A6)
|
(abs|acos|cos|atan|tan|asin|sin|ceil|floor|sqrt|log|ln)\([^)]+\)
)
)*
\s*=
"""
test_str = ("test text (1) pi=\n"
"test text (1 pi=\n"
"test text 1) pi=\n"
"test text (2) pi + 10 / 20=\n"
"test text (3) test pi ^ 10 / 20=\n"
"test text (30) 10 + 5=\n"
"test text (500) abs(10 + 5)=\n"
"test text (1) pi + 10 / 20=\n"
"test text 10*5=\n"
"test text pi / phi=\n"
"test text 10 mod phi=\n"
"test text 50 10 mod phi=\n"
"test text pi mod abs(phi)=\n"
"apple banana cherry apple 10 apple cherry banana hi 10 99+1=\n")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.