#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:^|\W)(@|)(sweetie|sweetiebot)(?:\W|$)"
Local $sString = "@@sweetiebot hi" & @CRLF & _
"@sweetiebot hoho" & @CRLF & _
"lol sweetie@" & @CRLF & _
"@ sweetie" & @CRLF & _
"/)sweetiebot" & @CRLF & _
"oh come on sweetiebelle."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")