// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:^|\W)(@|)(sweetie|sweetiebot)(?:\W|$)").unwrap();
let string = "@@sweetiebot hi
@sweetiebot hoho
lol sweetie@
@ sweetie
/)sweetiebot
oh come on sweetiebelle.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}