package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:^|\W)(@|)(sweetie|sweetiebot)(?:\W|$)`)
var str = `@@sweetiebot hi
@sweetiebot hoho
lol sweetie@
@ sweetie
/)sweetiebot
oh come on sweetiebelle.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}