re = /(?:^|\W)(@|)(sweetie|sweetiebot)(?:\W|$)/mi
str = '@@sweetiebot hi
@sweetiebot hoho
lol sweetie@
@ sweetie
/)sweetiebot
oh come on sweetiebelle.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end