using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\W)(@|)(sweetie|sweetiebot)(?:\W|$)";
string input = @"@@sweetiebot hi
@sweetiebot hoho
lol sweetie@
@ sweetie
/)sweetiebot
oh come on sweetiebelle.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}