package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d*;){1}(\d*);`)
var str = `99999;88888;22222;33333;44444;55555;66666;00000;12312;34534;56756`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}