re = /^(?:\d*;){1}(\d*);/m
str = '99999;88888;22222;33333;44444;55555;66666;00000;12312;34534;56756'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end