import re
regex = re.compile(r"^(?:\d*;){1}(\d*);", flags=re.MULTILINE)
test_str = "99999;88888;22222;33333;44444;55555;66666;00000;12312;34534;56756"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")