#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=,|^)XXX(?=,|$)"
Local $sString = "XXXCAP,XXX CAPITAL LIMITED" & @CRLF & _
"XXX,XXX POLYMERS LIMITED, 3455" & @CRLF & _
"YYY,XXX REP LIMITED,999,XXX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")