re = /(?<=,|^)XXX(?=,|$)/m
str = 'XXXCAP,XXX CAPITAL LIMITED
XXX,XXX POLYMERS LIMITED, 3455
YYY,XXX REP LIMITED,999,XXX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end