const regex = /(?<=,|^)XXX(?=,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=,|^)XXX(?=,|$)', 'gm')
const str = `XXXCAP,XXX CAPITAL LIMITED
XXX,XXX POLYMERS LIMITED, 3455
YYY,XXX REP LIMITED,999,XXX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}