using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=,|^)XXX(?=,|$)";
string input = @"XXXCAP,XXX CAPITAL LIMITED
XXX,XXX POLYMERS LIMITED, 3455
YYY,XXX REP LIMITED,999,XXX";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}