$re = '/(?<=,|^)XXX(?=,|$)/m';
$str = 'XXXCAP,XXX CAPITAL LIMITED
XXX,XXX POLYMERS LIMITED, 3455
YYY,XXX REP LIMITED,999,XXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);