#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9][0-9]?[0-9]?$|^1000$"
Local $sString = "0.0" & @CRLF & _
"0" & @CRLF & _
"1.2" & @CRLF & _
"0.1" & @CRLF & _
"0.23" & @CRLF & _
".2345" & @CRLF & _
"2.3" & @CRLF & _
"1" & @CRLF & _
"111" & @CRLF & _
"2" & @CRLF & _
"5" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"15" & @CRLF & _
"50" & @CRLF & _
"1000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")