import re
regex = re.compile(r"^[1-9][0-9]?[0-9]?$|^1000$", flags=re.MULTILINE)
test_str = ("0.0\n"
"0\n"
"1.2\n"
"0.1\n"
"0.23\n"
".2345\n"
"2.3\n"
"1\n"
"111\n"
"2\n"
"5\n"
"9\n"
"10\n"
"15\n"
"50\n"
"1000\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")