import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9][0-9]?[0-9]?$|^1000$";
final String string = "0.0\n"
+ "0\n"
+ "1.2\n"
+ "0.1\n"
+ "0.23\n"
+ ".2345\n"
+ "2.3\n"
+ "1\n"
+ "111\n"
+ "2\n"
+ "5\n"
+ "9\n"
+ "10\n"
+ "15\n"
+ "50\n"
+ "1000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}