// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9][0-9]?[0-9]?$|^1000$").unwrap();
let string = "0.0
0
1.2
0.1
0.23
.2345
2.3
1
111
2
5
9
10
15
50
1000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}