using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9][0-9]?[0-9]?$|^1000$";
string input = @"0.0
0
1.2
0.1
0.23
.2345
2.3
1
111
2
5
9
10
15
50
1000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}